Uploaded image for project: 'Solution Center'
  1. Solution Center
  2. SOL-640

CloudUI-Backend-Plugin Documentation - Installation/Update

    XMLWordPrintable

    Details

    • Type: Explanation
    • Status: Published
    • Affects Version/s: Exasol 6.1.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Symptoms:
      Hide

      This Solution explains the installation /update of the CloudUI-Backend-Plugin:

      If installed on the management node, the plugin handels the following tasks for a Cluster in AWS or Azure for you:

      • Add additional node(s) to a cluster (and increases DB size automatically)
      • Increase storage capacity via increasing disks of data nodes
      • Change instance type of data nodes (and increasing/decreasing DB size corresponding to the overall ram of new instance types)
      Show
      This Solution explains the installation /update of the CloudUI-Backend-Plugin: If installed on the management node, the plugin handels the following tasks for a Cluster in AWS or Azure for you: Add additional node(s ) to a cluster (and increases DB size automatically) Increase storage capacity via increasing disks of data nodes Change instance type of data nodes (and increasing/decreasing DB size corresponding to the overall ram of new instance types)
    • Explanation:
      Hide

      Installation

      The most recent plugins can be found in the download area: https://www.exasol.com/portal/display/DOWNLOAD/AWS+Plugins+and+AMIs

      If you need to update the plugin please refer to section "Updating" first.

      If the plugin is not already installed by default on the Management Node, this section guides you through the installation.

      1) Upload the package Plugin.Cloud.UIBackend-*.pkg from https://www.exasol.com/portal/display/DOWNLOAD/AWS+Plugins+and+AMIs in Exaoperation

      2) Afterwards the plugin can be installed on the management node via xmlrpc 

      #!/usr/bin/python3.6
      
      import ssl
      import xmlrpc.client
      server = xmlrpc.client.ServerProxy('https://admin:<password>@<ip_or_dns>/cluster1', context=ssl._create_unverified_context())
      # Test if the Plugin was uploaded correctly  
      server.showPluginList()
      --> ['Cloud.UIBackend-1.0.0']
      server.callPlugin('Cloud.UIBackend-1.0.0', 'n0010', 'INSTALL', '')
      
      
      

       or with direct SSH access to the management node via

      cd /usr/opt/EXAplugins/Cloud.UIBackend-1.0.0/exaoperation-gate/ && ./install
      

      Updating

      In order to update the plugin you need no uninstall and reinstall it.

      1) First you have to uninstall the plugin either locally with SSH access:

       

      cd /usr/opt/EXAplugins/Cloud.UIBackend-1.0.0/exaoperation-gate/ && ./uninstall
      

      or remotely via xmlrpc:

      server.callPlugin('Cloud.UIBackend-1.0.0', 'n0010', 'UNINSTALL', '')

      2) Then delete the plugin package

      3) Now install and update the new version as described in section "Installation"

      Usage

      For instructions on how to use the plugin, see SOL-649

      Show
      Installation The most recent plugins can be found in the download area: https://www.exasol.com/portal/display/DOWNLOAD/AWS+Plugins+and+AMIs If you need to update the plugin please refer to section "Updating" first. If the plugin is not already installed by default on the Management Node, this section guides you through the installation. 1) Upload the package Plugin.Cloud.UIBackend-*.pkg from https://www.exasol.com/portal/display/DOWNLOAD/AWS+Plugins+and+AMIs  in Exaoperation 2) Afterwards the plugin can be installed on the management node via xmlrpc  #!/usr/bin/python3.6 import ssl import xmlrpc.client server = xmlrpc.client.ServerProxy( 'https: //admin:<password>@<ip_or_dns>/cluster1' , context=ssl._create_unverified_context()) # Test if the Plugin was uploaded correctly server.showPluginList() --> [ 'Cloud.UIBackend-1.0.0' ] server.callPlugin( 'Cloud.UIBackend-1.0.0' , 'n0010' , 'INSTALL' , '')  or with direct SSH access to the management node via cd /usr/opt/EXAplugins/Cloud.UIBackend-1.0.0/exaoperation-gate/ && ./install Updating In order to update the plugin you need no uninstall and reinstall it. 1) First you have to uninstall the plugin either locally with SSH access:   cd /usr/opt/EXAplugins/Cloud.UIBackend-1.0.0/exaoperation-gate/ && ./uninstall or remotely via xmlrpc: server.callPlugin( 'Cloud.UIBackend-1.0.0' , 'n0010' , 'UNINSTALL' , '') 2) Then delete the plugin package 3) Now install and update the new version as described in section "Installation" Usage For instructions on how to use the plugin, see SOL-649
    • Category 1:
      Plattform Support - EXASOL on AWS

      Attachments

        Issue Links

          Activity

            People

            • Assignee:
              CaptainEXA Captain EXASOL
              Reporter:
              CaptainEXA Captain EXASOL
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated: