Uploaded image for project: 'Solution Center'
  1. Solution Center
  2. SOL-184

EXAplus compatibility with Java versions

    Details

    • Type: Explanation
    • Status: Published
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: EXAplus
    • Labels:
      None
    • Explanation:
      Hide

      Preface

      Although presented as a system-independent layer, java implementations come in different versions from different vendors. As a result, some changes in JRE/JDK sets require changes in software; EXAplus is no exception.

      List of Java versions and known limitations

      Unless stated otherwise, the following table uses Oracle (Sun) Java JRE as reference. As EXAplus is backwards-compatible, tests against new Java versions always use the latest EXAplus version mentioned in the table.

      Java Version Operating System Comment Solution
      Sun JRE 1.6 u?? Mac OS X "Works"  
      Sun JRE 1.6 u17 ... 1.6 u23 Windows, Linux No known problems Supported since EXAplus version 4.0
      Sun JAVA Version 7 Max OS X Possible deadlock on exit, may prevent saving of profiles Fixed with EXAplus version 5.0.3
      Version 7, Update 65 Windows, Linux A deprecated class was removed, breaking all EXAplus (gui) versions. Need to use prior Java version, may be a local copy in EXAplus installation folder. Problem fixed with EXAplus 4.2.12 and 5.0.0
      Version 7, Update 67 Windows, Linux No known problems.  
      Version 8, Update 20 Windows 7, 64bit No known problems  

      Disclaimer

      The above list is maintained manually and is far from complete.

      • A missing entry does not mean the version or operating system is not supported.
      • A given entry does not imply full support of the listed combination.
      • Please see the manual for more information
      Show
      Preface Although presented as a system-independent layer, java implementations come in different versions from different vendors. As a result, some changes in JRE/JDK sets require changes in software; EXAplus is no exception. List of Java versions and known limitations Unless stated otherwise, the following table uses Oracle (Sun) Java JRE as reference. As EXAplus is backwards-compatible, tests against new Java versions always use the latest EXAplus version mentioned in the table. Java Version Operating System Comment Solution Sun JRE 1.6 u?? Mac OS X "Works"   Sun JRE 1.6 u17 ... 1.6 u23 Windows, Linux No known problems Supported since EXAplus version 4.0 Sun JAVA Version 7 Max OS X Possible deadlock on exit, may prevent saving of profiles Fixed with EXAplus version 5.0.3 Version 7, Update 65 Windows, Linux A deprecated class was removed, breaking all EXAplus (gui) versions. Need to use prior Java version, may be a local copy in EXAplus installation folder. Problem fixed with EXAplus 4.2.12 and 5.0.0 Version 7, Update 67 Windows, Linux No known problems.   Version 8, Update 20 Windows 7, 64bit No known problems   Disclaimer The above list is maintained manually and is far from complete. A missing entry does not mean the version or operating system is not supported. A given entry does not imply full support of the listed combination. Please see the manual for more information
    • Category 1:
      Clients, Interfaces & Drivers - EXAplus

      Attachments

        Issue Links

          Activity

            People

            • Assignee:
              CaptainEXA Captain EXASOL
              Reporter:
              CaptainEXA Captain EXASOL
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated: